Hellfire103@lemmy.ca to Programmer Humor@lemmy.mlEnglish · 3 months agoTIFU by not using objects in my object-oriented programming courseworklemmy.caimagemessage-square24fedilinkarrow-up180arrow-down110cross-posted to: programmer_humor@programming.dev
arrow-up170arrow-down1imageTIFU by not using objects in my object-oriented programming courseworklemmy.caHellfire103@lemmy.ca to Programmer Humor@lemmy.mlEnglish · 3 months agomessage-square24fedilinkcross-posted to: programmer_humor@programming.dev
minus-squareddplf@szmer.infolinkfedilinkarrow-up4arrow-down12·3 months agoGood, OOP can suck my balls
minus-squarevext01@lemmy.sdf.orglinkfedilinkarrow-up13arrow-down1·3 months agoBalls.suck() is the correct syntax.
minus-squareRagingToad@feddit.nllinkfedilinkarrow-up5·3 months agoDon’t you need to declare new Balls() first? Or do you suck() Balls static?
minus-squarevext01@lemmy.sdf.orglinkfedilinkarrow-up3·3 months agoOr I didn’t using the correct naming convention!
minus-squarexigoi@lemmy.sdf.orglinkfedilinkEnglisharrow-up10·edit-23 months agoBallsFactory ballsFactory = new BallsFactory(); ballsFactory.setSuckable(true); Balls balls = ballsFactory.create();
minus-squarewhats_all_this_then@lemmy.worldlinkfedilinkarrow-up11·edit-23 months agoAll of this is okay, but it’s not production ready. This is what real production code looks like: SuckableFactory suckableFactory = new SuckableFactory(); Suckable balls = suckableFactory .setShape(SuckableShapes.round) .setCount(2) .create(); SuctionProvider mouth = SuctionProvider.getInstance(); SuckerFactory suckerFactory = new SuckerFactory(); Sucker sucker = SuckerFactory.create(): sucker.setSuctionProvider(mouth); sucker.setSuckable(balls); sucker.setIntensity(SuckerSuctionIntensities.medium); sucker.suckSuckable();
minus-squarewhats_all_this_then@lemmy.worldlinkfedilinkarrow-up14·3 months agoPython port: from ballsucker import suck suck()
minus-squareluciferofastora@lemmy.ziplinkfedilinkarrow-up2·3 months agoActually, it would be OOP.suck(ddplf.getBalls())
Good, OOP can suck my balls
Balls.suck() is the correct syntax.
Don’t you need to declare new Balls() first? Or do you suck() Balls static?
Or I didn’t using the correct naming convention!
BallsFactory ballsFactory = new BallsFactory(); ballsFactory.setSuckable(true); Balls balls = ballsFactory.create();
All of this is okay, but it’s not production ready. This is what real production code looks like:
SuckableFactory suckableFactory = new SuckableFactory(); Suckable balls = suckableFactory .setShape(SuckableShapes.round) .setCount(2) .create(); SuctionProvider mouth = SuctionProvider.getInstance(); SuckerFactory suckerFactory = new SuckerFactory(); Sucker sucker = SuckerFactory.create(): sucker.setSuctionProvider(mouth); sucker.setSuckable(balls); sucker.setIntensity(SuckerSuctionIntensities.medium); sucker.suckSuckable();
Python port:
from ballsucker import suck suck()
Actually, it would be
OOP.suck(ddplf.getBalls())